We are experiencing performance issues

Incident Report for KUARIO

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 13:08 CET

Monitoring

We have identified the cause of the issue and implemented the necessary improvements to prevent this from happening again.
Posted Jan 20, 2026 - 13:05 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 20, 2026 - 13:03 CET

Update

Our team is currently working hard to identify the cause of this issue. We will keep you informed as soon as more information becomes available.
Posted Jan 20, 2026 - 12:53 CET

Update

We are continuing to investigate this issue.
Posted Jan 20, 2026 - 12:52 CET

Investigating

We are currently investigating this issue.
Posted Jan 20, 2026 - 12:40 CET
This incident affected: KUARIO Platform (Main API, Payment API, Print API, Monitoring API, Scan API, Import API) and Services (Business Portal, Personal portal, KUARIO Apps).