Some top-up methods are not handled correctly.

Incident Report for KUARIO

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 15:08 CEST

Identified

There is currently an issue with one of our payment providers. The payment provider is working to resolve the issue as quickly as possible. Until this issue is resolved, we recommend choosing other payment methods where possible.
Posted Sep 05, 2025 - 10:37 CEST

Investigating

We are currently investigating this issue.
Posted Sep 05, 2025 - 09:55 CEST
This incident affected: KUARIO Platform (Payment API).